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Photoshop Tips & Tricks for Web Designers 
By Zac Van Note 
 
There are hundreds of tools and features in Photoshop. Learning the basics requires an investment of time 
and mental energy. Moving beyond the basics into true mastery requires even more time and an 
adventurous spirit. Of course, it helps to pull on the countless years of accumulated experience that millions 
of Photoshop users have amassed. That’s what this article is all about: distilling the useful tidbits learned by 
years of poking, prodding and just having fun experimenting with this great tool.  
 
Most of the tips presented will work in Photoshop 7, CS (8) or CS2 (9), but in some cases there are techniques 
that only work if you have certain tools and features. The screen captures were taken in Photoshop 7 and 
CS2. 
 

Layers 
Layers lie at the heart of Photoshop mastery, from simple tasks to advanced techniques. So I’ll start here with 
some layer tips and tricks to make your time in front of Photoshop more productive. 
 

Layer Shortcuts 
First, remember you can right-click (control-click on the Mac) and get a context-sensitive menu. This is handy 
in a few different ways. First, if you have a multi-layered image, you can right-click within your image and 
you’ll get a pop-up list to choose which layer to make active. This can be very handy in designing mock-ups 
of web page layouts—for instance, when working with text on top of buttons on top of backgrounds. 
 

 
 
Right-click on an image with layers to select which layer you’d like to edit. 
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Using shortcuts, you can even prevent multiple trips to the Layer menu and stay where the action is—the 
Layers Palette. By right clicking on a layer you can access most of the common functions. If you have a 
Layer Style applied to the layer, you can right click on the ‘f’ icon and get an additional menu with effect 
options. If you have the effects expanded (the triangle is pointing down) you can also right-click on the 
individual effects to access the options. If you just want to quickly get into all of the Layer Style options, just 
double-click on the ‘f’ icon or the individual layer effects. It won’t take you right to a specific effect, but it will 
open the entire dialogue box. 
 

Layer Blending Magic 
Speaking of the Layer Style dialog box… This dialog has some of the most useful and best-hidden features in 
Photoshop. On the left column you’ll notice there are several options. Under the top two is a list of all the 
styles: Drop Shadow, Bevel & Emboss, Glows, etc. The top two items are often overlooked but are very 
handy. The first one, Styles, is basically the same as the stand-alone Styles Palette. It’s handy though, 
because you can create a new style or apply an existing one, all at the same time you’re experimenting 
with your style options. Notice the Save Style… button on the right that’s always available in this dialog box. 
 
The second option on the left is even more useful and often unexplored. If the button says ‘Blending Options: 
Default’ you haven’t touched these options. If it says ‘Blending Options: Custom’, you have altered some of 
these settings, possibly without realizing it. Hopefully you’re familiar with blending modes like Multiply, Screen, 
Soft Light, etc. These can be used to affect the way a painting tool interacts with underlying pixels, or how 
pixels on one layer interact with the pixels of underlying layers. Normally you change this setting at the top of 
the Layers palette by choosing a mode (Normal is the default) and changing the Opacity or Fill as needed. 
Inside the Layer Style dialog box you can change all of these settings and more.  
 
For instance, the Blend If: area at the bottom has two sliders. You can fine tune how areas from the current 
layer blends with the underlying pixels by adjusting the top slider. You can move the highlight or shadow 
sliders back and forth as desired, but better yet, you can break the sliders apart so the area you choose to 
blend can be fine-tuned even more. To split them apart, just Alt-click (Option-click on Mac) on one side of 
the slider arrow and drag to the right or left. This will break the arrow in half and give you a range to blend 
with underlying pixels. If you drag the two halves close to each other they will stick together and you’ll have 
to Alt-click to split them again. 
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Layer Blending Magic happens here. The bottom area controls exactly how the current layer blends with 
underlying layers. 
 
Another underused and misunderstood option is Fill Opacity. If you have no effects applied and you change 
the Fill or Opacity sliders at the top of the Layers Palette, you’ll get the same results with either one. Once you 
add effects, the Fill Opacity (also part of the Advanced Blending options) affects the drawn pixels on the 
layer and not the Effects applied on the layer. For instance, if you had a drop shadow applied to text and 
you wanted the text to be transparent over a background image, but you wanted to retain the drop 
shadow, you can just change the fill opacity and watch your text become transparent while the drop 
shadow remained constant. If you tried to do this using the regular Opacity slider, the text and the drop 
shadow would start to fade out.  
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The Layers Palette’s Fill slider allows you to affect the parent layer while leaving the effects alone. 
 
In the Advanced Blending area of the Layer Styles dialog you’ll notice you have several checkboxes to 
determine how effects are applied and how the Fill Opacity will affect them. Take some time and play with 
the options that make sense to you. If you already use layer masks (another great technique) or vector 
masks, see how changing these options will change your Effects. 
 

Background Layer 
Most Photoshop documents start with a background layer which has some special properties you may or 
may not want. First, its position and opacity are locked, and then there’s no transparency. To change this, 
just double click it to give it a new name. The lock is gone and you can now remove pixels or add effects. 
But what if you created a new image or opened an existing image and it didn’t have a background layer? 
It’s not necessary to have a background layer, but sometimes it’s handy. Luckily, it’s easy to make one. You 
can turn any layer into a background layer. Just go to the Layer menu and select New > Background from 
Layer. 
 

 
 
Any layer can be turned into the Background Layer.  
 
Everyone has their own way of working, but I prefer to leave the background layer blank. I just put my image 
elements on layers on top of the background. Then, if I need to check my transparent effects I can toggle 
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the background on and off. Just make sure that the transparency grid is visible (check your Transparency & 
Gamut Preferences if you don’t see the transparency checkerboard).  
 

Fill Layers 
How about cases where you have removed some pixels around an object and can see the checkerboard? 
It’s nice to have the white background to check how it really will look when flattened into a JPG. In some 
cases you may even want another color for your background. If you’re mocking up a website and the 
background is black, wouldn’t it be easier if your base layer was a solid color and you could easily change 
your mind? In this case, you can create a new Fill Layer. What’s a Fill Layer? It’s another seldom-used goodie 
used to apply color to an entire layer. Just go to Layer > New Fill Layer. You get a choice of Gradient, Pattern 
or Solid Color (what you’d want for the white or black ‘background’). Once you get used to this method of 
applying color or gradients to an entire layer I’m sure you’ll be hooked. It saves several steps initially and 
then it’s much easier to change your mind. Double click on the layer icon and you can change your color or 
gradient at will. 
 

 
 
Fill Layers make it easy to add a solid background color, gradient or pattern in one step. 
 

Moving Layers 
When it comes to moving layers around you will usually use the Move Tool. I’ve found that many people 
don’t take advantage of the Move Tool options. If you’ve never used Auto Select Layer, give it a try. It will 
automatically select the top-most layer you click on. If you have dozens of layers, this can save you time and 
your sanity. There’s also an option to Show the Bounding Box (Show Transform Controls in CS2). This will draw 
handles around your object, just like you were in Transformation mode. While you’re in this mode you can 
move your layer, resize it and rotate it just like Free Transform mode. In CS2 you get a new option to Auto 
Select Groups which can be handy or annoying depending on how your layers are selected. If you’re a 
Photoshop veteran, it will probably take some time to get used to CS2’s new method of selecting and 
grouping layers.  
 

 
 
The Move Tool Options in Photoshop 7 & CS 
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The Move Tool Options in Photoshop CS2 
 
 
Of course you can also turn these handy options off. Sometimes there’s no easy way to work with your image 
in Auto Select Layer mode. For instance, text is hard to select in this mode. You have to click right on the 
shape and with small text this can be difficult. It is also difficult to select small objects and transparent areas. 
Any area that has Opacity of 49% or less will not be selected while in this mode. You’ll have to turn the option 
off and click on the layer in the Layers Palette. 
 

Hiding Layers 
To show or hide layers you can click each little eye on or off, but that gets old. If you have several layers to 
turn on or off, you can press in the eye area and drag up or down. But wait, there are more little tricks. If you 
want to hide everything but the layer you’re working on, hold ALT (Option on the Mac) and click on the eye 
icon. This will hide every layer except the one you clicked on. ALT-click once more to show every layer.  
 
If you’re a well-organized Photoshop user, you have named each of your layers or at the very least you have 
all of your layers organized into Layer Sets (called Layer Groups in CS2). Those little folders help keep 
everything tidy and if you’re mocking up a web interface with lots of text, buttons and images, these sets will 
keep you out of trouble. Starting with Photoshop CS you can group your sets inside sets so you can get even 
more organized. If you’ve done all this work up front, you can use the ALT-click method to select the entire 
Layer Group. As expected, this will show just the Layer Group and hide all the rest. ALT-click it again to bring 
them all back. 
 

Layer Duplication Magic 
Now let’s say we’re developing several interface ideas in several different Photoshop files. In document A 
you’ve got a search box with a nice little search button. You want to move the individual layers or the entire 
Layer Group to document B. Just right-click on the layer or Layer Group label (the text part) and select 
Duplicate Layer… or Duplicate Layer Group… A dialog box will open up letting you choose another 
document. This can be one you already have open or you could duplicate it into a new document. The 
layer(s) will move intact to the new document. Assuming the image size is the same between documents, 
the duplicated layers will be in the exact same position. 
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You can duplicate a layer to another document with a simple right-click on the layer. 
 
Sometimes you’re not so well organized and you want to drag several layers from one image to another. 
Just link the layers together in document A. Then, using the Move tool, drag the layers into document B. The 
trick is that you can’t drag them from the layers palette. You must drag from the image itself. If you don’t get 
all the layers, check your Move tool settings. If you have Auto Select Layer turned on in the options bar and 
you don’t click right on the layers to be moved, it will select and move only the layer you clicked on. 
 

Modifying Layer Effects 
A well-hidden layer trick is that you can detach a layer effect from the layer it was originally applied to. For 
instance, you’ve applied a drop shadow to a picture of a bottle. The shadow isn’t of the cast-shadow 
variety, so it looks like it’s lying flat on the surface. Wouldn’t it be nice to detach the shadow from the bottle 
and modify it separately? No problem! Just take the layer in question, make sure you can see the drop 
shadow effect and right-click on the ‘drop shadow’ label. Select Create Layer(s) and you have your original 
layer, sans effects and a new flattened effects layer.  
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Create Layer will detach a layer effect from its parent layer. You can not re-attach an effect after using this 
feature. 
 
Now you can take that shadow and transform it, erase parts of it or whatever else will complete the effect. In 
CS2, the new Warp capabilities added to the transform options allow you to create complex shadow 
transformations to follow the contours of an object. 
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Create easy and flexible drop shadows by detaching a drop shadow layer effect from its parent layer. It 
becomes rasterized and editable as a standalone layer.  
 

Grab Bag of Cool Web Tips 
 

ImageReady Oddities 
For some reason, ImageReady and Photoshop are similar but not completely integrated. This lack of 
integration has yielded some interesting results in the form of unique features that the other program doesn’t 
have. For instance, ImageReady has some cool ready-made vector shape tools that are handy for web 
design but it lacks other vector capabilities that would also be useful. Photoshop doesn’t have the ready-
made tools, but it has more overall vector flexibility.  
 

Eyedropper Plus 
ImageReady’s eyedropper does something Macromedia figured out years ago. Rather than just selecting a 
color within the active image or even within ImageReady, you can actually select the color of anything on 
the screen…or if you’re using two monitors, something on the other screen. The trick is to select the 
eyedropper, press down in your image in ImageReady, and without letting go, drag across your screen to 
the desired color. If you try to just click outside of ImageReady, it will shift focus to another application.  
 
This technique works great for matching colors to existing images, web page interfaces and more. In CS2, 
this feature even works in Photoshop. In previous versions it only worked in ImageReady. 
 

ImageReady Previews 
ImageReady is always in ‘Save for Web’ mode. You can always access the Optimize Palette and you always 
have the Original, Optimized, 2-up and 4-up options at the top of any image window. Toggle between those 
modes with Control-Y (Command-Y on Mac). Just make sure you toggle back to Original mode to make 
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your edits. Otherwise you’ll get a lot of beeps telling you something is wrong (though it won’t always tell you 
to switch back to Original mode). 
 

Preview like a Mac (or vice versa) 
If you design on a Windows machine or a Macintosh, chances are high that some of your users will be using 
the other platform. “So what?”, you may ask. Well, the video settings for Mac and Windows are very 
different. Depending on a number of factors, your images will be at least 10% lighter or darker on the other 
platform. That means your light colors could completely disappear or your darker colors might completely 
turn to black. To see what the other side sees in ImageReady, just go to View > Preview > Standard 
Macintosh Color or Standard Windows Color. In Photoshop, you can do a similar trick using View > Proof 
Setup > Macintosh RGB or Windows RGB. This is always a good idea before making your final color selections. 
Keep in mind that even on the same platform, people will have their Brightness, Contrast and other monitor 
settings all over the place. You can only account for so much, but this should help in tweaking your colors. 
 

   
 
Check how your graphics will look on a Macintosh or Windows computer without buying another machine. 
 

Fast and Easy Hexadecimal Numbers 
Sometimes you want to match the color of text, backgrounds or other elements on your web pages to a 
color in a photograph. Most people know you can click the eyedropper on the photo to select the desired 
color. Then you can double-click on the Foreground color picker and see the Hex value at the bottom. 
Wouldn’t it be handy to see the Hex number as you move around the image? No problem! Just open the 
Info palette, and from the palette menu, select Palette Options and change either the first or second color 
readout to Web Color. You’ll get a live update as you move the eyedropper around listing the Hex numbers 
next to the RGB values. Just string them together in order and you’ve got the hex code for any color. 
Photoshop CS2 gives you many additional options. Some correspond to tips listed below. 
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Change how you preview Color Picker selections in the Photoshop 7 & CS Info Palette. 
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The Photoshop CS2 Info Palette gives you more information than ever. 
 
 

Squeeze your Images Down Automatically! 
Many websites have a file size limit (or suggested size limit) for graphics and animations. If you’re creating 
banner ads (animated or not) there’s almost always a cap on file size. Sometimes it’s hard to know how best 
to squeeze your image or animation down to fit. Stop worrying and let Photoshop handle it! In the Save for 
Web dialog box, just to the right of the Settings menu is a pop-up menu (triangle icon). Choose Optimize to 
File Size and you’ll get a few options. Type in the desired file size and give it a starting point (use current 
settings or auto-select GIF/JPEG) and Photoshop will do its best to bring it down to size. You can do the same 
thing in ImageReady from the Optimize palette menu. Of course, this method doesn’t always give you the 
best visual results, so you may have to simplify or rethink your image, but size-wise it always does the trick. 
 

   
 
Let Photoshop (or ImageReady) do the thinking. Tell it how big you want the file size and it will make it look as 
good as possible while cramming it into that small file. 
 

Squeeze Your GIFs and JPGs without Save for Web 
Sometimes you want to save a JPG for the web, but you don’t want to use Save for Web. For instance, if 
you’re setting up a Batch Action, the Save for Web feature doesn’t always work. You can use the normal 
Save command, select your file type and go from there. The major problem is the small image preview that 
is appended to the file. With Save for Web, you never get an image preview tacked onto the file. When you 
use the Save dialog you do get the preview tacked-on by default. To turn it off, go to Photoshop 
Preferences, select the File Handling category and change Image Previews to Never Save. If you’re going 
back and forth from print to web, you may want to choose, Ask When Saving. 
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You don’t need Save for Web to squeeze the most from your images, but you’ve got to change this 
preference to get the smallest files.  
 

Speeding up Photoshop 
Photoshop is one of the hungriest apps out there, eating up all the processor speed and RAM you can throw 
at it. But how can you be sure what Photoshop needs? First, check your system’s specifications against the 
published recommendations for your version of Photoshop. Photoshop CS2 is still new to market and it’s 
requirements are hefty:  
 
Windows 
Intel® Xeon™, Xeon Dual, Intel Centrino™, or Pentium® III or 4 processor  
(of course the last few generations of AMD processors will also work fine) 
Microsoft® Windows® 2000 with Service Pack 4, or Windows XP with Service Pack 1 or 2  
320MB of RAM (384MB recommended)  
650MB of available hard-disk space  
1,024x768 monitor resolution with 16-bit video card  
 
Macintosh 
PowerPC® G3, G4, or G5 processor  
Mac OS X v.10.2.8 through v.10.4 (10.3.4 through 10.4 recommended)  
320MB of RAM (384MB recommended)  
750MB of available hard-disk space  
1,024x768 monitor resolution with 16-bit video card  
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If your system doesn’t meet these requirements then there’s no hope. Assuming it does, here’s a few tips to 
make sure you’re running as fast as possible.  
 
Set up a dedicated scratch disk. If at all possible, install a second hard drive (internal or external Firewire/USB 
2.0) and set it as your primary scratch disk under Photoshop Preferences. It will nudge you to do this when 
you first install Photoshop, but it doesn’t remind you again. Hard drives are cheap and can be a fast way to 
speed up Photoshop. If you just use it as your scratch disk, you can get a small hard drive (2GB or larger) 
practically for free if you troll flea markets, online clearance sales, eBay and such. 
 

 
 
In Preferences, select a scratch disk other than your primary hard drive (C:\ or Startup) as your First scratch 
disk. If you don’t have one (as illustrated above), run out and buy one. 
 
Allocate more RAM. In Photoshop Preferences under Memory & Image Cache, you can increase the 
amount of RAM Photoshop can use. Setting it above 75% is usually too high and your system will be starved 
for resources. 50%-75% is a good place to try. Of course, the more memory you allocate to Photoshop, the 
less you have for your system and other applications to use. If you crank it up high, make sure you still have at 
least 200MB available for the rest of your system. 
 



 Photoshop Tips & Tricks for Web Designers 
Zac Van Note 

Copyright © 2005 DMXzone.com All Rights Reserved 
To get more go to DMXzone.com  

Page 15 of 16 

 
 
If you have RAM to spare, allocating more to Photoshop can speed you up. 
 
Install more RAM. Most machines can handle 1GB or 2GB and some even accept 4-8GB! How much 
memory you have installed already, the type of chips used and the amount of slots in your computer will 
affect how much or even if you can install more RAM. If you’re not sure, check with your system 
manufacturer or a reputable dealer and they should be able to assist you. But how much do you need and 
how much is too much? There’s almost no such thing as too much. 2GB seemed ridiculous a few years ago, 
but now is common. With Photoshop 7 and CS you can get some work done with 512MB, but to get the most 
out of Photoshop (especially CS2), I would start with 1GB and buy as much as you can afford or your system 
will allow. If you want some hard evidence that your system is starving for more RAM, go to the Info box at 
the bottom left of your document window. It normally tells you the document’s file size, but if you click on the 
black arrow, it gives you other options. Select Efficiency. Work on an image like you would on a normal 
project. After working for a bit, watch the number next to Eff: If it goes below 75% you should think about 
getting more RAM. If it dips below 50%, you’re writing to the hard disk constantly and you need to buy more 
RAM! In Photoshop CS2 you can also check these settings using the Info palette. 
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Get proof that you need more RAM by checking the Efficiency rating in Photoshop 7/CS or… 
 

 
 
…by checking the Efficiency rating in Photoshop CS2. 
 

When Nothing Else Works 
Sometimes you just can’t explain it. Photoshop isn’t working right and you don’t know why. When you’ve 
tried everything you can think of and it still doesn’t work, try these tips in order:  

1) Reboot your machine. If it still doesn’t work, go to step 2: 
2) Delete or Reset the Preferences file. It doesn’t always fix the problem, but it works most of the time. 

You should try resetting the Preferences first. Press and hold Shift + Alt + Control (Windows) or Shift + 
Option + Command (Mac) immediately after launching Photoshop or ImageReady. If that doesn’t 
work, try deleting the prefs file. Look for a file called ‘Adobe Photoshop CS2 Prefs.psp’. Put your 
version number in place of CS2. You may have to run a search for the file. On Windows, it’s generally 
located in: Documents and Settings\<your username>\Application Data\Adobe\Photoshop 
<version>\. On the Mac, it’s usually in: <user’s home>/Library/Preferences/Adobe Photoshop 
<version> Settings/. 

 
So that’s the Photoshop tip round-up for today. Hopefully you’ve found a few useful tidbits that keep you 
running full speed to Photoshop nirvana. In addition to this site, I would recommend checking out Photoshop 
User Magazine (http://www.photoshopuser.com), Adobe Studio (http://studio.adobe.com), and my site 
Creative Fuel (http://www.creativefuel.org) for more resources. 
 
 
 
 

http://www.photoshopuser.com/
http://studio.adobe.com/
http://www.creativefuel.org/
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